Opened 3 years ago

Closed 3 years ago

Last modified 21 months ago

#479 closed enhancement (duplicate)

Include stream as tempate in XML Template

Reported by: Maxim Reznik Owned by:
Priority: major Milestone: 18.0
Component: Matreshka - XML Processor Version:
Keywords: Cc:

Description

We need a way to avoid expression substitution in nested stream of an template. It's error prone to have this as default. See #426 as example.

I propose to add an extra directive

<mtl:include expression="stream"/>

to explicitly force substitution in the stream from given variable.

Change History (3)

comment:1 by Maxim Reznik, 3 years ago

In 5817:

Add mtl:evaluate to XML Processor

Refs #461, #479

comment:2 by Maxim Reznik, 3 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #461

comment:3 by vadim.godunko, 21 months ago

Milestone: 0.8.018.0

Milestone renamed

Note: See TracTickets for help on using tickets.