Opened 9 years ago

Closed 9 years ago

#117 closed defect (fixed)

Makefile.install gnatls commands produce blank lines

Reported by: john.marino Owned by:
Priority: minor Milestone: 0.2.0
Component: Matreshka Version: 0.1.1
Keywords: Makefile install Cc:

Description

In the Makefile.install file, there are several gnatls | sort | sort > file.list commands that cause the subsequent install commands to choke.

The reason for this is that the gnatls command output starts with a blank line, at least on FreeBSD. The blank line is propagated to sort and uniq, so the install command throws an error on the first line.

I fixed it by removing the blank line by piping the output of the gnatls command to "grep -v '$$'" before the sort command.

I have attached a diff file to illustrate the changes need to install matreshka on FreeBSD, including a fix for xargs -a.

Attachments (1)

Makefile.install.diff.txt (12.2 KB ) - added by john.marino 9 years ago.
makefile.install diff

Download all attachments as: .zip

Change History (5)

by john.marino, 9 years ago

Attachment: Makefile.install.diff.txt added

makefile.install diff

comment:1 by vadim.godunko, 9 years ago

Duplicate of #116

comment:2 by vadim.godunko, 9 years ago

In [2011]:

Remove blank lines from gnat ls output to be compatible with BSD
systems.

Refs #117.

comment:3 by vadim.godunko, 9 years ago

In [2012]:

Merge change 2011 into 0.1.x branch.

Refs #117.

comment:4 by vadim.godunko, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.